One thought on “Flare 1.0 Mac OS version now available

  • March 17, 2018 at 9:56 am
    Permalink

    Sooo happy about the release of 1.0! I just downloaded this build.

    Sadly, I wasn’t able to launch it on Mac OS X 10.9.5 (Mavericks), which is still quite whitespread. Another two machines are even running Mac OS X 10.6.8. You don’t specifiy the system requirements, but I suppose you’re not using any critical frameworks from the newest OSes.

    > ./Flare
    > dyld: Library not loaded: /usr/local/opt/sdl2/lib/libSDL2-2.0.0.dylib
    > Referenced from: /Applications/Spiele/Flare.app/Contents/MacOS/./Flare
    > Reason: image not found
    > Trace/BPT trap: 5

    I then noticed that Flare.app brings libSDL2, but the binary looks at the typical installation path that Homebrew would use, and doesn’t use it’s own libraries.

    Installing libSDL2 by Mac Ports and symlinking the Homebrew patch doesn’t work:
    > $./Flare
    > dyld: Library not loaded: /usr/local/opt/sdl2/lib/libSDL2-2.0.0.dylib
    > Referenced from: /Applications/Spiele/Flare.app/Contents/MacOS/./Flare
    > Reason: Incompatible library version: Flare requires version 9.0.0 or later, but libSDL2-2.0.0.dylib provides version 8.0.0
    > Trace/BPT trap: 5

    There’s also an official libSDL2 installer for the average user that installs into /Library/Frameworks:
    https://www.libsdl.org/download-2.0.php

    Reply

Leave a Reply

Your email address will not be published.